Zend Guard Loader

(aamato) #1

Alguem pode me ajudar ? Estou tentando instalar o Scriptcase em um servidor linux com PHP 5.3, ou seja, tenho que instalar o Zend Guard Loader ao invés do Zend optimizer que só funciona no PHP 5.2
O problema é que o Zend Guard não oferece compatibilidade retrograda, ou seja, quando rodo o scriptcase, recebo o seguinte erro:
Fatal error: Incompatible file format: The encoded file has format major ID 3, whereas the Loader expects 4 in /home/____/public_html/scriptcase/index.php on line 0

Como posso solucionar isso sem ter que instalar uma versão antiga do PHP ?
Obrigado

(Lucimar Magalhães) #2

Boa tarde,

Eu tive o mesmo problema e não consegui resolver… utilizei o canal de respositório da zend e instalei o Zend Server c/ PHP 5.2, no meu caso um CentOS6.
Com isso vc só vai precisar do Zend Guard Loader, pode desabilitar o Optimizer+

Abraço

(Max Veras) #3

Boa Tarde,

Em ambiente de desenvolvimento, o Scriptcase não roda com PHP 5.3.
Apenas em ambiente de produção, onde as aplicações são publicadas depois de finalizadas.

(Alexandre Pereira Bühler) #4

Terá de esperar o Scritpcase 6 que irá rodar com php e Zend Guard loader