Usar Ajax

(JulioOliveira) #1

Onde foi parar o Usar Ajax (sim/não)?
Tentei criar um evento (onblur) e recebi a mensagem de aviso: “Altere a flag “Usar Ajax” para “Sim” em Configuração, para que o evento Ajax tenha efeito”.

Minha aplicação é um formulário e em configurações não encontrei mais essa opção, nem mesmo em uma aplicação de Controle.

Uso SC5.2.31

Obrigado!

(George Carvalho) #2

Por default já é SIM.

(JulioOliveira) #3

Então seria bom vocês verificarem a mensagem do próprio sc: “Altere a flag “Usar Ajax” para “Sim” em Configuração, para que o evento Ajax tenha efeito”.
E realmente não está funcionando nenhum desses eventos.

Obrigado.

(George Carvalho) #4

Amigo não trabalho na NM.

(Cleyton Euler) #5

[risos]

(JulioOliveira) #6

Desculpe, mas é que nem sempre o pessoal da netmake está bem identificado.
Como esse que postou “apenas” [risos].

(Cleyton Euler) #7

Julio,

Também não trabalho na Netmake. Apenas achei engraçado a confusão, no bom sentido. Não escrevi mais nada pq não tinha mais o que acrescentar ao tópico.

Abraço.

(paulomarcelo) #8

Acredito que retiraram esta opção do Scriptcase pois na versão 5.1.0018 esta opção está disponível em Projeto > Valores Padrão
Primeira opção Usar ajax: O sim O Não, porém na versão 5.2.0031 não existem mais esta opção e no web help(da versão 5.2.0031) continua existindo.

(Cleyton Euler) #9

Acho que agora o uso do ajax já é habilitado sempre.

(JulioOliveira) #10

Obrigado pelos esclarecimentos.
Essa aplicação que apresenta esse erro foi importada da versão do SC4, talvez seja essa a origem principal do erro.
Solucionei o problema criando a aplicação do zero na versão 5.
Por sinal ao converter versões do SC sempre aparecem “coisas” muito estranhas que por vezes nos levam a refazer todo um trabalho/projeto.

(Cleyton Euler) #11

Passei muita raiva quando foi migrar projeto da V4 para V5!!!

Vamos ver o que nos aguarda quando formos migrar da V5 para V6.