Undefined property:

Pessoal no q errei aki:
Não consigo achar o erro

$message = "Óla {NomeCliente} , ";
$message .= “

”;
$message .= {Mensagem};
$message .= “


”;

$mensage = “Código do Cliente:”." “.{CodigoCliente}.”
".“Nome do Cliente:”." “.{NomeCliente}.”
".“Email do Cliente:”." “.{EmailCliente}.”
"."
".“Mensagem:”." ".{Mensagem};
$anexo1=$this->Ini->path_doc.’/’.{Anexo};

sc_lookup(dsmail, “select smtp, contasmtp, senhasmtp, emailsmtp from tblconfig”);
if ({dsmail[0][0]} <> ‘’)

{

   $smtp       = {dsmail[0][0]}; 
   $contasmtp = {dsmail[0][1]}; 
   $senhasmtp     = {dsmail[0][2]};
   $emailsmtp  = {dsmail[0][3]};

}

else

{
sc_mail_send(“", "", "", "*”, {Para}, {Titulo}, “$mensage”, “H”, “”, “$anexo1”);
}

if ({sc_mail_ok})
{
echo “”;

  sc_redir(atentimento_geral.php);

}else{
sc_error_message(“Erro ao enviar!”);

}

DA ESSE ERRO AKI AO ENVIAR O EMAIL

Undefined property: ReportarBug_apl::$sc_mail_ok
Erro ao enviar!

[RESOLVIDO]

$message = "Óla {NomeCliente} , ";
$message .= “

”;
$message .= {Mensagem};
$message .= “


”;

$dataenv = sc_date_conv({Data},“aaaammdd”, “dd/mm/aaaa”);

$mensage = “Código do Cliente:”." “.{CodigoCliente}.”
".“Nome do Cliente:”." “.{NomeCliente}.”
".“Email do Cliente:”." “.{EmailCliente}.” “.{Mensagem}.“Data do ocorrido:”.” ".$dataenv;
$anexo1=$this->Ini->path_doc.’/’.{Anexo};

sc_lookup(dsmail, “select smtp, contasmtp, senhasmtp, emailsmtp from tblconfig”);
if ({dsmail[0][0]} <> ‘’)

{

   $smtp       = {dsmail[0][0]}; 
   $contasmtp = {dsmail[0][1]}; 
   $senhasmtp     = {dsmail[0][2]};
   $emailsmtp  = {dsmail[0][3]};

sc_mail_send("$smtp", “$contasmtp”, “$senhasmtp”, “$emailsmtp”, {Para}, {Titulo}, “$mensage”, “H”, “”, “$anexo1”);

}

else

{
sc_mail_send("", “”, “”, “”, {Para}, {Titulo}, “$mensage”, “H”, “”, “$anexo1”);
}

if ({sc_mail_ok}) {

echo “”;

  sc_redir(atentimento_geral.php);

}else{

  sc_error_message("Erro ao enviar!");

}

.