Segurança no login

(dgidgio) #1

Alguém sabe se o é mesmo obrigatório o formulário de login ficar sempre com a segurança desactivada?

Existe alguma possibilidade de activar a segurança e não dar o aviso de ‘usuário não autorizado’?

Cpmts

(Haroldo) #2

Não tem como. me diz porque fazer isso?

(dgidgio) #3

Apenas porque a opção de segurança está disponível e como se trata do form de login (que tem as credenciais dos utilizadores) poderia ser melhor ter segurança activada.
Mas se mesmo com a segurança desactivada, o formulário estiver seguro, então está tudo ok.

Obrigadão

(Bernhard) #4

Bom dia,

Sim é possível, vá em Configuração --> Meu ScriptCase e defina “Habilitar uso de segurança”, “Habilitar uso de senha” como não.

Note que em momento algum o Sr. deve passar URLs do seu ambiente de desenvolvimento para os usuários finais, pois a segurança apenas estará ativa no ambiente de produção.

Atenciosamente,
Bernhard Bernsmann

(Haroldo) #5

Se eu entendi bem, ele quer ativar a segurança do Login e não aparecer a mensagem de Usuário não autorizado, como a tela de login é a primeira a ser carregada, ela não pode ter a segurança habilitada.

(Bernhard) #6

É verdade Haroldo, eu que interpretei incorretamente.

@topic, como o Haroldo já falou, isto não é possível, a segurança está desabilitada no control_login para que o usuário possa acessar a aquela aplicação de login, sem que a mensagem de “usuário não autorizado” apareça.

Atenciosamente,
Bernhard Bernsmann

(dgidgio) #7

Compreendido.

Viva o scriptcase. :):slight_smile:

(dgidgio) #8

Tenho um pequeno problema no formulário de login quando uso sc_sql_injection que não sei resolver.

Guardo uma data como variável global, faço assim:

$sm_global_datadetrabalho = {datadetrabalho};
sc_set_global($sm_global_datadetrabalho);

a data de trabalho guardada fica sem pelicas: 20120125

Mas eu quero fazer uso do sc_sql_injection, então faço assim:

$sm_global_datadetrabalho = sc_sql_injection({datadetrabalho});
sc_set_global($sm_global_datadetrabalho);

Mas neste caso a data de trabalho fica guardada com pelicas: ‘20120125’
Quando noutro formulário coloco um campo data com valor inicial [sm_global_datadetrabalho] , a data aparece mal.

Como resolvo isto? Alguém sabe?

(Bernhard) #9

Respondi no seu outro tópico.

Atenciosamente,
Bernhard Bernsmann