SC perdendo item 'Configuração da Visualização' dos campos

(rrma) #1

Gostaria de saber se mais alguém tem problemas com os itens da “Configuração da Visualização” nos campos de forms.
Aqui a todo instante o SC perde as configurações de fonte, negrito, cor, alinhamento.
Um saco ficar marcando a mesma coisa várias vezes pq ele não grava direito as opções escolhidas.

Rodrigo

(Cleyton Euler) #2

Sempre acontece comigo. Tem que clicar no botão salvar. O recurso de salvar automático acho que não funciona para estes itens.

(rrma) #3

Mesmo eu salvando, a medida que vou trabalhando no form as configs vão voltando ao padrão.
A NM deve rever isso aí, faz tempo que está assim.
Rodrigo

(system) #4

Irei análisar o que pode estar ocorrendo.

(system) #5

Testei aqui rapidamente e não vi erro algum tanto no auto save quando ao clicar no botão salvar.

Estão utilizando a versão mais recente do SC? Qual o servidor web e qual o navegador utilizado?

(Cleyton Euler) #6

Comigo só acontece as vezes quando uso auto save, geralmente o útimo campo editado.

Windows 2003 R2
SC 5.2.005
Apache e PHP instalado pelo instalador do SC.

(rrma) #7

Comigo acontece sempre. O campo que mais tenho problema é o de alinhamento.
Uso o SC 5.02.005 num server ubuntu 8.04, php 5.2.13 e banco do SC em mysql 5.0.51a-3ubuntu5.4.
Não sei se é por acaso, mas percebo muito esse problema quando trabalho com blocos bem complicados de montar.
Posso até disponibilizar meu sc para testes Rafael, caso acho interessante, pois uso ele online num cloud locaweb.
Abraço.
Rodrigo

(Adesoft) #8

Rodrigo, também aconteceu comigo hoje, ao entrar novamente no form os campos estão em branco:

Campo de Cor; Tamanho e o alinhamento estava o padrão, porém o formulário ainda esta sendo visualizado com as definições que eu fiz, se eu compilar ele ele volta para o padrão deixei um form sem compilar somente abri ele, e depois recompilei e o form voltou sem a cor, tamanho padrão.

Tentei simular um padrão para ver o erro porém ele ocorre mais ainda sem um padrão:
Passo para simular o erro:

  1. Colcoar um tamanho de fonte diferente do padrão, por exemplo: 16
  2. Colocar uma cor na fonte:
  3. Alterar somente o CSS do Campo e o CSS do OBJETO INPUT
  4. Ir alté os campos selecionados e altera a ordem, não Clicar no Salvar, ir direto para um campo, o SC irá salvar automaticamente.
  5. Mudar a cor e fonte de outro campo, salvar
  6. Voltar a editar os primeiros campos,

Fiz estes passaos entre 4 vezes 2 ocorreu o erro, estou testando mais e tentar criar um padrão de para e o erro.

At.

Adeilson de Oliveira
THS do Brasil

(rrma) #9

Comigo acontece praticamente desse mesmo jeito, geralmente quando faço este processo:
Configurando a formatação dos campos;
Configurando blocos;
Configurando ordem dos campos na seleção de campos;

Faço esse loop várias vezes e o erro sempre acontece.
Valeu.
Rodrigo

(George Carvalho) #10

Este problema acontece com frequencia mesmo antes da versão 5.

(system) #11

Agradeço pelas informações, iremos averiguar.

Postarei aqui sobre qualquer novidade.

(Cleyton Euler) #12

Aconteu comigo agora:

Depois de configurar a visualização de um campo, ao alterar alguma coisa neste campo (que não seja configurações de visualização) e salvar, ele perde as configurações de visualização. Mas somente do campo que eu modifiquei, os outros continuam com as configurações de visualização.