Re: Enviar Emaisl no GMail - Retorna erro = RESOLVIDO.

(pauloper) #1

Ola pessoal,

Tenho um formulario de envio de emails e funciona 100%em varios servidores.
Ocorre que um novo cliente tem seus emails no Gmail e informo os parametros e recebo um erro:

Uncaught Error of type [Swift_ConnectionException] with message [There was a problem reading line 1 of an SMTP response. The response so far was:
[]. It appears the connection has died without saying goodbye to us! Too many emails in one go perhaps? (fsockopen: #0) ]

O cliente me enviou os dados e configuei o Outlook e tudo OK, os mesmos parametros no meu
form nao envia; estou achando que é alguma segurança do GMail.

Alguem ai usa o GMail para enviar emails ou tem alguma dica ??

Obrigado.
Paulo.

(Haroldo) #2

gmail utiliza portas diferentes para smtp, tente verificar.

(pauloper) #3

Então… estas portas foram informadas no Outlook que fuinciona normalmente.
As mesmas configurações no SC retornam o erro acima. Estranho !!!

(pauloper) #4

Pessoal, Resolvido o envio de email no GMail.
Como o amigo Haroldo, falou as portas sao diferentes.
Ja tinha colocado as portas corretas e mesmo assim
nao tinha funcionado.
E como GMail utiliza conexão segura, sc_mail_send, deve
obrigatoriamente usar tipo_coxexao = S e pronto.
Coloquei S no tipo conexao e funcionou 100%.

Att,
Paulo.

(waae) #5

Paulo, por favor, tem como vc me falar a porta que vc usou?
se puder passar a linha de comando eu agradeceria…

(pauloper) #6

Claro, ai esta a linha completa que eu uso aqui:

sc_mail_send($vsmtp,$vusuario,$vsenha,$vorigem,$vdestino,{assunto},$mensagem,“H”, {copias}, “”, 465, “S”);

No Gmail a Porta e Conexao Segura são importante, sem eles os emails não são enviados.

Att,
Paulo.

(LuisGustavo) #7

Ola amigos, tentei utilizar a conta do google app que usa a porta 587 e cript. TSL, como configurar isso no sc_mail_send,
uma vez que só alterando a porta e habilitando o php_openssl no php não esta funcionando.

sc_mail_send($vsmtp,$vusuario,$vsenha,$vorigem,$vdestino,{assunto},$mensagem,“H”, {copias}, “”, 587 , “S”);

Alguém pode fazer o teste para ver se funciona?!

Grato

Luis Gustavo