Problema no Evento Ajax Onchange (5.2.00/5.2.01/5.2.02 e 5.2.03)

(Adesoft) #1

Desde o lançamento da Versão 5.2.00 até a versão 5.2.03, continua o problema no evento ajax

Uma aplicação Form, que tem um campo com lookup de pesquisa, chamando um Grid para captura um campo esta apresentnado problemas:

Exemplo:

Um formulário onde temos um campo numérico id_cliente, ele tem um lookup para apresentar o nome do Cliente, este campo tem uma ligação um grid para uma consulta de cliente para capturar o campo id_cliente.

Ao clicar na lupa de pesquisa para capturar o id_cliente na consulta, ele retorna o id_cliente corretamente para o formulário, porém ai começa o problema:

  • O Campo é capturado porém era para no exato momento ele mostrar o nome do cliente pois tem um evento Ajax onChange esperando, a o campo fica sem focu e não aparece o nome do cliente.

  • Ao clicar o TAB ou ENTER (Já esta configurado a tabulação automatica) ele passa para o outro campo porém não apresenta o nome do cliente.

  • Ao apagar o conteúdo do campo e digitar um outro id_cliente e teclar ENTER ou TAB, ai sim aparece o nome do Cliente.

O Suporte Janilson acompanhou este problema desde o lançamento da 5.2. O processamento do campo Ajax no evento onChange esta demorando e junto com o lookup (pesquisa, lupa) não esta funcionando.

Adeilson de Oliveira
THS do Brasil

(system) #2

Bom dia Adeilson.

O problema já foi encontrado, e já foi enviado desde o primeiro dia ao setor de desenvolvimento para correção.

(Adesoft) #3

Problema no Evento Ajax Onchange (5.2.00/5.2.01/5.2.02 /5.2.03 e 5.2.04)

O Problema no Campo Ajax OnChange ainda continua a versão 5.2.04 não consta esta correção. Desde o lançamento da versão 5.2.0, reportei o problema na pesquisa lookup, uma facilidade que coloquei para o meu cliente, que agora depois da atualização para corrigir outros problemas, acabou parando de funcionar.

Tenho a conciência que a Netmake tem uma prioridade para as correções, mais para mim esta também é muito importante, não adianta eu passar para o meu cliente novas funcionabilidades que o sistema esta permitindo sendo que as anteriores deixaram de funcionar.

Peço a equipe da Netmake uma correção desde problema e outros qua surgiram e estão no forum.
Em uma semana saiu 4 atualizações. Conforme sugestão minha no forum e na área de suporte antes de sair uma versão oficial lançar a versão Beta para que possamos testar, pois o SC é um produto que nós desenvolvedores apresenta para o mercado, ninguém quer saber se o fabricando cometeu erros ou não, eles querem saber quando nós vamos concertar o problema gerado por nós.

Peço atenção não só ao meu item mais a de todos que estão no forum de Bugs pois todos são importantes também.

Adeilson de Oliveira
THS do Brasil

(Hudson Marques) #4

Olá Adeilson, seu problema já foi resolvido?
Já atualizei até a versão 5.02.0005 e continuo com o mesmo problema.
A NetMake prometeu uma solução até a sexta passada mais nada, já estou muito preocupado com isso pois tenho aplicações que devriam ser lançadas à alguns dias e não pude lança-las pois estão prejudicadas por este bug.

(Adesoft) #5

Problema no Evento Ajax Onchange (5.2.00/5.2.01/5.2.02/5.2.03/5.2.04)

Prezado
Hudson Marques, parte voltou ao normal, porém a versão 5.2.05 que corrige este problema apresentou outro problema que estou publicando hoje a tarde, alguns campos ajax númericos não estão funcionando, quando a aplicação é chamada pelo nome do servidor da rede, quando coloco ip 12.0.0.1 ela aceita.

Recomento para você recompilar todas as aplicações com a versão 5.2.005 reiniciar o SC, Apache para verificar se vai voltar.

Tenho mais 4 Bugs para reportar da versão 5.2.05 creio que até o final do dia vou conseguir, porque tb estou tento problemas nas aplicações publicadas nos clientes estão a 3 semanas sem atualização.

AT.

Adeilson de Oliveira