Problema na Publicação.

(Régis Matos) #1

Ex. Quando eu marco para publicar somente 3 formulários… ele pega vários outros formulários e publica junto e para piorar as x ele publica um formulário antigo tipo imagina que vc já atualizou/gerou fonte do menu principal… e faz a publicação de um formulário… ele simplesmente gera também o menu mais o meu antigo…

estou publicando da forma padrão e recomendada sem nenhuma rotina adicional.

Alguém já teve esse problema…

A minha extrutura de pasta de organização esta tipo assim…

contratos_publicidade
contratos_assinatura
financeiro
contas_receber
contas_pagar

Não só as pastas mais os nomes das aplicações tambem são nessa estrutura…

Ex.

contrato_publicidade.php
contrato_comercial.php

ou seja muitas delas com o ( _ ) e com inicio de nomes =

será que isso que esta dando problema???

se for deve ser algum Bug na publicação…

(Haroldo) #2

Nunca passei por iso, ja tentou criar um template de publicação?

(Régis Matos) #3

Não.
Estou usando a publicação Típica (recomendada), antes eu seleciono as aplicação que quero publicar… mais mesmo assim acaba publicando outras que não selecionei…

(Cleyton Euler) #4

Estou com este problema!!! Mando gerar algumas aplicações e quando vou ver o zip tem coisa que não selecionei e não sei de onde ele tira versões velhas de algumas aplicações.

Remédio: Criei uma pasta chamada Publicacao e uso a opção de publicar no servidor.

(George Carvalho) #5

Já passei por esse problema, fiz uma atualização manual e corrigiu.

George Carvalho

(Régis Matos) #6

Fiz a atualização manual… criei uma pasta e em x de publicar compactando… publiquei direto no servidor…

Diminuiu o problema mais mesmo assim ele acaba publicando algumas aplicação não selecionada… e para piorar desatualizada… pior quando atualizo no cliente para arruma um detalhe e acrescentar rotinas novas acaba ferra com outras rotinas que esta funcionando normal.

Alguém mais esta passando ou passou por isso???

(Jeová Soares) #7

Olá,

Também tenho este problema…
O que está acontecendo é que o sc5 está se perdendo no contador de publicações (zip_1, zip_2, etc). Como o contador de publicações é iniciado novamente, ao fazer uma publicação ele não apaga o zip da publicação anterior de mesmo número. As vezes ele faz a atualiação das aplicações dentro do zip existente e as vezes não, baixando o arquivo anterior intacto.
Uma forma de resolver isso é apagando os arquivos de publicação manualmente no diretório tmp do sc5, assim ele irá gerar novos arquivos. O que no meu caso é mais complicado, pois o servidor do sc5 é administrado pela equipe de rede e não tenho acesso. Não dá pra ficar pedindo pra eles apagarem isso pra mim.