O arquivo não foi gerado com a versão 5 do Scriptcase

(wetsite) #1

Prezados,

Gostaria da ajuda da turma. Estou tentando importar sistemas exemplos como sc_rh, sc_loja e quando chego na parte importar aplicações, quando escolho o arquivo .zip e clico em continuar, aparece a mensagem “O arquivo não foi gerado com a versão 5 do Scriptcase”. Tem alguma forma de importar essas aplicações? Alguém da turma aí tem esses sistemas exemplos na versão 5 para me enviar. Desde já agradeço.

Obs.: Se alguém tiver a versão que funciona na versão 5, por gentileza envie para meu email wetsite@hotmail.com.

Welington Santos

(waldemargo_ol) #2

Está incompatibilidade e devido alguns recursos novos da Versão ScriptCase 5

Por este motivo eu acho que a empresa bloqueou os projetos da versão anterior, pois os sistemas exemplos foram feitos na versão 3 e convertido para versão 4

Para você solucionar este problema você terá que estalar a versão 4 e depois importar os projetos.

Gere o arquivos para versão 4 e faça backup

Entre no ScriptCase 5 no menu Administrativo e mande converter os projetos da versão 4 para versão 5, lembrando que depois que você converter muitas coisa teriam que ser adaptadas.

Mas acho que não vale à pena usar estes projetos, pois eles estão cheio de falhas e a sistemática deles não são legais…

Se você quiser usar para forma de aprendizado tudo bem, mas se for para usar como projeto não aconselho.

Espero ter ajudado

(Diogo Toscano) #3

A nova versão 5.1 ja pode importar os projetos feitos para a mesma. :slight_smile:

(Haroldo) #4

Não entendi direito…
A última release importa projetos da versão 4? É isso mesmo?

(waldemargo_ol) #5

Você argumentou que quando ia mandar importar dava erro dizendo que o sistema não foi gerado na versão 5 correto…

Eu não sei se a versão 5.1 do ScriptCase foi corrigida este problema, mas tenta importar os projetos agora direito sem precisar ter que gerar na versão 4

Se não der certo posta novamente aqui dizendo

(Diogo Toscano) #6

Não, quiz dizer que agora voce pode importar os sistemas de exemplos que foi feito para a mesma(5.1), pois antes nos nao tinhamos disponibilizados os sistemas para downloads.

Importação de outras versões não eh possivel pois a estrutura do banco onde armazenamos as aplicações são diferentes, menos campos e/ou menos opções que a versão 5. Então se liberassemos a importação provavelmente ia dar erro.
É necessario essa proteção.

(Haroldo) #7

Desculpa, sou analista de sistemas a bastante tempo e sei que é perfeitamente possível desde que o Fornecedor da ferramenta esteja disposto a criar a possibilidade. Tudo é uma questão de conceito, e talvez por uma estratégia comercial só é possível converter todos os projetos de uma versão para a versão seguinte, sem disponibilizar a possibilidade de continuar com as duas versões, migrando apenas um o outro projeto, e mantendo os projetos na versão superior.

No meu ver o mesmo algorítimo utilizado na conversão poderia ser utilizado na restauração do Backup, o que tornaria o trabalho de nós; fábricas de softwares, onde temos diversos projetos, e não podemos simplesmente migrar todos eles de uma só vez, de uma versão para outra nova (que geralmente não é estável).

Tudo é uma questão de foco, e o foco do Scriptcase, vejo eu, é menos voltado para empresas que fabricam sistemas (softhouses), e mais voltado para os segmentos do Governo, que podem investir em mão de obra, servidores, etc, para ficar testando suas aplicações desenvolvidas, e geralmente não sofrem pressões e cronogramas de prazo curtos para entrega de tarefas.

(wetsite) #8

Galera,

Agradeço cada um que tentou ajudar. Quem falou que poderia instalar outros sistemas não dá porque a licença é inerente a versão, ou seja, tentei instalar versões mais antigas, porém como não consigo registrar, não consigo importar os sistemas. Na nova versão v5.1 vem o sistema de album e o news que já ajuda bastante, além de outros novos, disponibilizados agora também, como helpdesk, online shop, … assim resolve parte do problema.

Agradeço a atenção de todos

Welington Santos

(Diogo Toscano) #9

Concordo Harold, mas é mais por proteção mesmo e performance.

Infelizmente temos bilhoes de clientes e se em cada importação fossemos testar versão, rodar conversor, copiar arquivos necessarios … de fato funcionaria, obvio. Todos nos somos desenvolvedores e sabemos que é possivel, so que ficaria uma carroça.

Mas se muito nao me engano, voce pode converter apenas um projeto de da v4 para a v5 nao é? Nao participei desse processo, mas eu n lembro se voce converte tudo ou nao. Mas acredito que a ideia seja da pessoa converter e iniciar o trabalho. Não quer dizer que voce vai converter logo tudo, mas ja que vc tem a versão 4 e com os sistemas publicados, a ideia seria vc ter a versao 5, converter pra 5 os sistemas( o que nao quer dizer que vc vai publicar tudo na 5) e aos poucos ir publicando os sistemas que vc converteu, testeu e rodou.
A respeito do backup é outros 500 em relação a conversão dos sistemas antigos.

Mas tudo bem. Não quero fugir ao tópico.

Vamos fazer do atual o melhor possível. Em que podemos ajudar? esse é o ponto. Estou aqui respondendo como mais um desenvolvedor. Nao pela empresa. O que posso fazer? Em que eu posso ajudar e passar meus conhecimentos? essa é minha ideia aqui como um desenvolvedor qualquer. Vou ajudar da melhor maneira :slight_smile:

(Haroldo) #10

Performance?
Segurança?
Desculpa, mas já existe um “IF” verificando a versão do backup, basta desviar para rotinas que interpretariam a restauração com a conversão, caso não seria uma restauração simples. Discordo quanto a performance.

Segurança: Onde falharia a segurança nesse processo?

E afirmo, que não da para trabalhar nas duas versões simultaneamente, e ir convertendo aos poucos os projetos da versão anterior, verifique aí com seu Departamento de Desenvolvimento, mas desde a versão 3, que foi quando iniciei, a filosofia de conversão é a mesma, a base da nova versão é totalmente zerada, perdendo qualquer projeto existente lá, e todos os projetos da versão anterior são convertidos.

Ainda não me convenceu.