MASCARA FORMULARIO

(Almeida) #1

Ola pessoas,

É o seguinte vou tentar explicar:

Criei um formulario, um campo do tipo “numero”, 6 dígitos, auto-incremtno, campo label e chava primária.
Coloquei na máscara de exibição as seguintes para testes;
“xxxxxx”,“zzzzzz”,“999999”,“aaaaaa”,"******",“000000”,"######", nenhuma dessas máscaras consegui o resultado desejado.

Qual o resultado desejado?
Queria colocar “zeros a esquerda do numero”.
ex: 000001

Quando queria que aparecessem os zeros?
Quando eu clicasse para atualizar o registro.

E como aparece?
Aparece assim: “1”.

Ja tentei varias formas, se alguém sabe como me ajude.
Vlw.

Suspeito que seja um BUG, pois tenho outros formulários criados
com campos do tipo número com máscara “xxxxxx”, que funcionam
perfeitamente.

(George Carvalho) #2

Tentou a opção do campo ‘Completar à Esquerda com’

(wanderlanlima) #3

em Máscara de Exibição, coloque xxxxxx

(Almeida) #4

Já coloquei xxxxx, e todos os exemplos sitados a cima.
A opição “completar a esquerda com:” não aparece em campos do tipo número.

Ainda suspeito que seja bug.

(wanderlanlima) #5

Uma pergunta:

Esse formulario foi feito antes dessas ultimas 4 versões de ajustes de bug’s ?

Se sim, crie outro formulario dessa mesma tabela só pra teste, e coloque a mascara nesse mesmo campo, pra ver se a mascara se aplica.
Me de retorno !

(Almeida) #6

Foi feito depois delas, mais estou atualizando para a última para testar.

(Almeida) #7

Mesmo atualizada a versão não funciona. Alguem conseguiu fazer isso?

(wanderlanlima) #8

Na versão 5.1.xxxx, funciona !

(Almeida) #9

Já testeii de todo jeito não funcionou.
Se alguem conseguiu me posta um exemplo sei la.

Vlw