Formulario de alteração - mensagem processamento não desaparece

Ao efetuar uma alteração no registro de uma aplicação de formulário, aparecem uma mensagem PROCESSAMENTO… e a mesma não sai da tela.

Isso acontece quando tem algum erro na aplicação. Digo algum erro pq não sai nenhuma mensagem de erro, mas isso acontece desde a V4. Comigo já aconteceu de ser máscara errada, tipo de campo, na aplicação e no bd diferente, entre outros.

O problema só ocorre na alteração, na inclusão não apresenta o mesmo comportamento.

Estou com um problema parecido desde que atualizei para a versão 5.02.004. O botão “atualizar” não faz nada quando clico. Meus forms mais complexos ficaram todos assim, já nem sei mais o que fazer.
O suporte me mandou uma versão anterior, 5.01.018, que resolveu um alguns outros problemas que detectei na atualização, porém, o botão atualizar permanece com o mesmo erro.
Como seu botão funciona, exibindo a mensagem ajax, acredito que seja um problema diferente, mas gostaria de saber se isso passou a acontecer depois de algum update.
Grato.
Rodrigo

No meu caso o botão update funciona, mas a mensagem processando… não desaparece, fiz uma alteração e verifiquei que no banco de dados os dados foram alterados.

Depois dessa bendita atualização minha vida virou um inferno, as coisas que estavam funcionando corretamente começaram a ter resultados estranhos, não consigo evoluir no meu projeto, sem falar que tive que reinstalar o SC pois a atualização automática melou meu ambiente todo.

Tem código nos eventos do formulário? Talvez alguma mundaça em alguma macro sc fica gerando esse problema. Já aconteceu comigo.

Existe código no evento onRefresh, retirei o código do evento, mesmo assim, a mensagem Processando… fica na tela, coloquei no modo debug mas não aparece nada !!!

Essa era uma aplicação que funcionava perfeitamente, depois dessa última atualização do SC um monte de coisas deixou de funcionar.

Tem como eu voltar para a versão anterior ? o downgrade garante que minhas aplicações atualizadas rodem na versão anterior ?

Cleyton

Consegui identificar o problema, no meu formulário existem dois campos do tipo CEP, um para o endereço normal, e outro para o endereço de cobrança da empresa, quando coloco o segundo campo do tipo CEP a mensagem de processamento não sai da tela, quando eu coloco o segundo campo CEP como texto a aplicação funciona sem travar na tela pocessamento.

Acredito que isso é um BUG do SC. Estou resolvendo desta forma para poder adiantar meu projeto, porém preciso que isso seja resolvido o quanto antes.

Se vc fez um backup/exportação do seu projeto antes do update um downgrade é tranquilo. Reinstale a release .18 e importe o backup.

Sobre dois campos CEP no mesmo frm acho que é BUG do SC.

Bom dia, Senhores

Por acaso na opção em “Aplicação -> NAvegação ->Mensagem Após a Atualização”, existe alguma mensagem existente nesta opção, caso não, verifique se existe algum codigo existente nos evento OnAfterUpdate, OnBeforeUpdate ou OnvaLidate.

Se possibel ligue o modo debug para verificar.

Senhores

Esse é mais um problema da versão 5.2, eu tive que voltar a versão anterior 5.01 e todos os meus problemas acabaram. Estou conseguindo desenvolver meu Sistema sem problemas.

Não atualizem o SC para a versão 5.2 !!!

A Netmake tem que tirar essa versão do ar e fazer uma grande revisão apartir das informações postadas no Forum. !!!

Também estou com os mesmos problemas.
Estou usando a versão 5.02.0004.

Ricardo Cesar

Liberamos a release 5.2.006, hoje (10/02), corrigindo este problema.
O Problema erá referente algumas versões do PHP, Quando se utilizava a a opção de “Mensagem Após a Atualização” em (Aplicação -> Navegação), a mensagem ficava processando e não saia, da TELA, corrigimos este problema.

.