Erro campo tipo CEP

(wetsite) #1

Prezados,

Peço a ajuda de todos, desenvolvi um cadastro de contatos que possui um campo do tipo cep, a aplicação na minha máquina, funciona perfeitamente, porém quando publico e envio para o servidor na net, quando clico no campo cep aparece a seguinte mensagem:

“Os arquivos de acesso ao CEP estão corrompidos.
Estes arquivos podem ser baixados do site do Scriprcase e copiados para o diretório onde foi instalado o PROD,
dentro da seguinte estrutura: …/prod/cep/arquivos.”

Já fiz de tudo, publiquei novamente e reenviei, baixei o pacote como sugere a mensagem e enviei, e mesmo assim permanece o mesmo problema. Isso já aconteceu com algum dos Srs, peço a ajuda de todos.

Welington Santos

(George Carvalho) #2

Você tem que transferir os arquivos compactados e descompactar no servidor, só assim funciona.

(Diogo Toscano) #3

Exatamente como o amigo George Carvalho citou.

Para a busca ser mais rapida, é lido com os ponteiros (como em c) procurando a proxima posicao e percorre os arquivos de cep. o que acontece as vezes ao transferir por ftp ou winscp … é que eles mudam o caracter de enter danificando a estrutura e consequentemente o md5(id) do arquivo.

a solução eh enviar compactado e descompactar no servidor.

(wetsite) #4

Bom dia Pessoal,

Agradeço a ajuda, farei os testes e em breve posto o resultado.

Welington Santos

(wetsite) #5

George Carvalho e Diogo,

Agradeço a ajuda dos Srs, é examente o que falaram, fiz seguindo as orientações e funcionou perfeitamente.

Welington Santos

(Diogo Toscano) #6

:slight_smile: