Erro aplicação consulta GRID e conexão postgres

(Ighor Moura) #1

Estou tentando criar um aplicação de consulta grid porém está me apresentando está mensagem:


O que poderia ser? Eu conferi o comando SQL e outras aplicações que usam a conn_postgres está normal ou faltam alguma configuração específica que não estou vendo?

(Bruno) #2

Bom dia @ighorpm, a caixa de mensagem esta na frente do comando sql, tira outro print sem a caixa de mensagem pra podermos ver o comando sql se esta tudo certinho.
OBS: Abre a caixa do sql toda pra podermos ver o comando sql todo por favor.

(pauloper) #3

Verifique tua conexão e teste se esta conectado com o banco.

(Ighor Moura) #4

A imagem do SQL

(Ighor Moura) #5

Sobre a conexão com o banco de dados está normal
outras aplicações compilam normalmente e rodam 100% certo.

(Bruno) #6

Realmente parece estar tudo certo, você tentou gerar a grid mesmo com esse erro que aparece?

(Alexandre Bühler) #7

Este grid parece corrompida.
Experimente criar outra com outro nome e teste.
Se funcionar a outra grid é porque esta ai corrompeu.

(Ighor Moura) #8

Sim, o mesmo erro aparece, ademas esse grid é o segundo que havia recriado desse mesmo formulário também achando que poderia ser cache e etc…
e já havia acontecido antes quando tentei gerar um grid de outra tabela do sistema.

(Marco Ruben) #9

Tenta copiar todo o SQL da aplicação Grid e colocar no SQL Builder
Se executar corretamente, de certo é um erro que foi gerado no momento da criação da GRID.
Nota também, se a lista de campos estão com seus tipos iguais ou referentes ao tipo de dados das colunas da tabela que está no banco de dados.

(Ighor Moura) #11

O problema persiste apenas na execução rápida, porém, ele consegue gerar o código fonte sem apresentar erros, então, incorporei o link do formulário a um menu e após e ser aberto pelo menu consegui visualizar.