CRITICO!!! Passagem de parâmetro - Consulta / Formulario

(LuisGustavo) #1

Boa tarde sr(a)s…

Passei o final de semana tentando resolver um dilema que era simplesmente passar como parametro o id de uma consulta para um formulario simples…

Tentei de diversas maneiras … sc_redir, sc_link, com variavel global… logicamente que cada um na sua sintaxe… porem unica solução que encontrei foi criar uma ligação da minha consulta como se eu fosse edita-la e ai criar um campo LABEL onde na onload eu atribui o seu conteúdo como sendo um link conforme abaixo.

{gerar_cdm} = “<a href=”…//form_tb_cdm/form_tb_cdm.php?id_etiqueta="."{tran_id}"."" >Gerar CDM";

No meu formulario onde eu precisa da variável eu ia testando com as linhas abaixo e ele sempre ele me retornava vazio para a variavel id_etiqueta quando eu utilizava as funcoes:

Linha de teste
echo " get ==== " . $_GET[“id_etiqueta”] . “
”;
echo " post === " . $_POST[“id_etiqueta”] . “
”;
echo " global = " . [id_transferencia] . “
”;

sc_link (Eu crirei um campo html_imagem na minha consulta, coloquei os parametros, tudo conforme a regra… ele chama a aplicação mas nada de mostrar o conteudo)

sc_redir(Para esta função eu criei um botao php, tbm tudo conforme o figurino, ele chama a aplicação mas nada de trazer o conteudo da variavel id_etiqueta)

Tentei usar todas as maneiras existentes mostradas aqui no forum e no help, nenhuma funcionou…

ex: (Só para mostrar os comandos encontrados no forum

sc_redir(http://localhost:85/ramati.php?emp_cod=$var_emp_cod) //Com paramentro junto
sc_redir(ramati.php, emp_cod={var_emp_cod}) //Com paramentro separado

o mesmo com o sc_link… diversas maneiras todas rodam sem erro, porem não retornam o valor de id_etiquta…
Agora pergunto… essas funções realmente funciona com alguem nesta situação… consulta / Formulario??? não encontrei ninguem no forum que obteve sucesso.

Sendo que a unica solução que encontrei foi a descrita acima… fazer uma ligação para editar o registro, incluir um campo label e alterar seu conteudo conforme comando acima…

Bom é isso… só quero ter certeza que não estou fazendo nenhuma besteira e deixar uma solução para alguem que encontre a mesma dificuldade.

Att.

(Haroldo) #2

DOIS TÓPICOS PARA O MESMO ASSUNTO?

(system) #3

Tópico duplicado.