Conexão ODBC - Alguem conseguiu fazer funcionar?

(joaquim) #1

Tenho um projeto usando Mysql que esta funcionando normal, mas os outros 2 projetos que usam conexão ODBC um com ACCESS e outro com SQLserver não funcionan com a V5, já tentei conexão direta também da o mesmo erro :
2 = simplexml_load_string() [function.simplexml-load-string]: Entity: line 1: parser error : Malformed declaration expecting version
C:\Arquivos de programas\netmake\v5\wwwroot\scriptcase\devel\class\xmlparser\nmXmlparserConnFilters.class.php 101

(Cleyton Euler) #2

Quanto ao erro que vc informou não sei dizer o que é extamente, mas tenho projetos rodando com ODBC normalmente. Em conexões ADO com plataformas MS dá erro em campos de data e hora. Quando testa a conexão com o banco tens sucesso?

(Haroldo) #3

isso deve ser problemas de ambiente, execute o diagnosis para avaliar.

(joaquim) #4

Oi Cleyton Euler, já tentei a conexão ADO, da o mesmo erro.

Harold,a primeira coisa que eu verifiquei foi o ambiente.

esta tudo correto…
só não funciona…
esperei tanto por nada!

(Rodrigo Lins) #5

Bom Dia Joaquim,

Qual o sistema operacional utilizado?

No windows vista e 7, vi vários problemas deste tipo, por causa do próprio sistema operacional ter mudado a forma de conectar mesmo deixando as bibliotecas antigas para compatibilidade.

De fato a solução que vi em alguns casos foi através de ODBC, mas a conexão é criada com sucesso? No Sql builder lista as tabelas e retorna algum valor?

O erro está sendo apresentado em qual momento exatamente?

Rodrigo Lins.