CAMPO IMAGEM (NOME DO ARQUIVO)

(bento) #1

Olá pessoal!

Estou necessitando utilizar uma logo num formulário report pdf, mas não estou conseguindo
setar a imagem para o campo, Criei no Banco um campo chamado c_logo onde eu coloquei o
caminho completo da imagem (pasta), na aplicação criei um campo tipo imagem( nome arquivo),
e no onrecord da aplicação eu seto o valor do campo c_logo para este campo da aplicação,
porem não aparece imagem nenhuma. Por favor alguem pode me dar uma dica de como usar
corretamente esse tipo de CAMPO?

OBRIGADO!

BENTO.

(robertobru) #2

Veja o exemplo do help “publicação” no que diz respeito às pastas. Veja se você já criou a pasta tmp e também quando for publicar, observe atentamente as opções dos caminhos das imagens e arquivos temporários do SC.

(bento) #3

Ola Roberto,

Obrigado pela atenção, veja bem, eu ainda não publiquei essa aplicação, estou executando ela no ambiente de desenvolvimento (scriptcase), eu copiei a imagem para o diretorio “C:\Arquivos de programas\netmake\v4\wwwroot\scriptcase\file\img\logo.jpeg”, e criei na minha tabela no banco um campo chamado ‘C_LOGO’ tipo varchar que contem o caminho do arquivo como descrito acima, e no evento ‘onrecord’ eu seto o valor do ‘C_LOGO’ para um campo tipo imagem (nome do Arquivo) chamado ‘CE_LOGO’ só que qdo eu executo a consulta o campo ‘CE_LOGO’ vem vazio. Vc pode me dar uma dica passo a passo como fazer isso de maneira correta, já pesquisei em todos os lugares possiveis e imaginaveis e não encontrei a solução, e para piorar eu não tenho contrato de suporte com a netmake.

Valeu, e obrigado pela força!!!

Bento.