Campo Imagem (Banco de Dados)

Meus Caros Criei um formulario com um campo que upa o logotipo do cliente, porem quando submeto o formulario ele apresenta o erro:

{ŠaÉ’#ŒG½š¢¹An‘ȲvL»>â¢÷f»è8Z$~S«0aՏJ±Ê32Èw(è3SRF)X†Rš•×È¢7`g€?Ò›q³”¤²DÎaÊ«ÎÞ/ݝØÆveÂyD–éêQ4‘ %LDŠÏžÌͧrºÞ‹$j…êzûñUï¯ÌÐ$žj¨W@<•úR©+šÁÝ·ºñ»eû9k’p©ƒŒŸj†ÏÀºŽ®ÆââUÚ_@àTӍõ3nÇU¡|<ŽÎ!(R\0<±9ÏÐWY¡é+åÄ°Œ±åBMoRÖ:iɵcA¶WjÆ1»®ÞÄzÕˆmc™PÎ[tªaÓŸZᔍ[å‰ ì?c¹·„ nFa~ôä1\] tcàéƒZEèav:kHæ²òšLE–eGúÀj8rP‰Ø‡‚ Z®”4аdXÞ>Û¹üjgÔRö%0ÃnFIÿ\0ëTJDJ6e{°ÆFXÝ\•Ü£¡¢+Ø¾É HHÚÄt?JÊ.äTZUÃ¤ñ.ÈÀÚFó„C\0(=óÖ­˜Gb´ç‚Ï‘ò\0GçQ[ùЙ€ÚÓ)á_¡§Ëd Ý[K¢Í*2Î8cÓéRJâÝ–T” = åi™^äqÏö¨·4™\0åN?•hÛê"ÆO0Ä#9e¿4›*Z˜HâI„˜9Âr:gÚ¤L²4Ì]œ˜1Èaôª“Ї6‰äùW0/Êx+ê)/'šéâT( ôÏ5šf±™fâp ’9 ñU®&Uµï\–*®&íè#:‹XP!ÃyäÓ“t\0l‘v

Já tentei Imagem (Nome do arquivo), mas ele reporta o erro em:

Parse error: syntax error, unexpected T_IF in C:\netmake\v5\wwwroot\scriptcase\app\samples\form_concurso\form_concurso_apl.php on line 1541

Abraços
DeivitePopo

O suporte reportou que já foi corrido e na próxima atualização estará solucionado.

George

Só não sei por que esperar tanto para soltar uma correção tão importante, já que está pronta. To com projeto parado esperando apenas esta correção para implantar no cliente.

Idem

Cleyton Euler,

Esta previsto para hoje, espero.

Pessoal parece que a atualização ja foi disponibilizada porem quando faço a inserção com o campon imagem (banco de dados) ele insere no banco a seginte informação ao invez da imagem:

ÿØÿàJFIFÿíJPhotoshop 3.08BIMí Resolution8BIM FX Global Lighting Anglex8BIMFX Global Altitude8BIMóPrint Flags 8BIM Copyright Flag8BIM’Japanese Print Flags 8BIMõColor Halftone SettingsH/fflff/ff¡2Z5-8BIMøColor Transfer Settingspÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿèÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿèÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿèÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ

Porem o campo nome da imagem (banco de dados) ele insere, mas não sei se ele exibe a imagem e como faço pra ele exibir a imagem, porque ate entao eu acho que ele guarda so o nome da imagem não o caminho.

Abraços

Estava acontecendo o mesmo comigo, uso MySql, alterei o campo de BLOB para MEDIUMBLOB e funcionou.

Bom Dia,

Todos conseguiram utilizar o tipo de dados Imagem? Creio que já foi corrigido na última release do ScriptCase 5.

E com relação a questão do Deivite, quando utiliza o tipo de dado BLOB ou similar no banco de dados, de fato vai armazenar informações que não seri o nome da imagem, vão ser várias informações, estaria correto. Para você visualizar se funcionou, poderia ver no próprio formulário ou em uma aplicação de consulta colocando o campo do tipo Imagem(Banco de Dados).

A mesma coisa para o campo do tipo Imagem (Nome do Arquivo), e caso esteja no diretório padrão a imagem estará sendo colocado no diretório /scriptcase/file/img/

Espero ter ajudado de alguma forma.

Rodrigo Lins.

Olá. Tenho um problema parecido com o Banco de Dados SQL Server da Microsoft. O scriptcase até gera a imagem na pasta temp, porém o conteúdo do arquivo de 1 Kb parece vazio. Alguém já teve este problemas?

.