Botão "atualizar" inoperante na maioria dos forms (v5.02.004 -> v5.1.018)

(rrma) #1

Após gerar todo meu projeto na atualização 5.02.004 a grande maioria dos meus forms ficou com o botão atualizar inoperante (além de outros bugs com ajax). Com ajuda do suporte, paralelo a 5.02.004, instalei “do zero” a versão 5.01.018, que passou a gerar os forms funcionando normal, porém, tive que exportar meu projeto a partir da 5.02.004 para importá-lo na 5.01.018. Acontece que os forms que eu já tinha feito há mais de 90 dias, em versões até anteriores do SC, funcionava normal o botão atualizar e, agora, mesmo regerando fontes com a 5.01.018, deixaram de funcionar. Os forms novos, gerados com a 5.1.018 funcionam normal, o problema são os forms antigos, que passaram pela 5.02.004 e que exportei para a 5.1.018. Em nenhum deles o botão atualizar funciona, parecendo que não há nenhum evento configurado no onClick. Em alguns deles, após clicar no botão o form paralisa a navegação, só navega se carregar o form novamente.

Gostaria de saber se algum dos colegas teve o mesmo problema e se alguém do suporte NM estiver acompanhando o forum, gostaria de saber também se houve algum problema detectado/corrigido neste sentido.
Estou passando por vários problemas por conta desses acontecimentos, chegando a modificar manualmente no banco os dados necessários, o que atrapalha muito a rotina de trabalho da empresa.
Só pra constar, uso o SC num server linux ubuntu 8.04 com banco mysql 5.0.51a e php 5.2.13.
Um abraço a todos.
Rodrigo Araújo