30% OFF para compra e renovaÇÃo. Comprar agora

Autor Tópico: Botão NOVO não aparece no GRID (Consulta) quando é Mestre/Detalhes  (Lida 6874 vezes)

saulobborges

  • Expert
  • *****
  • Mensagens: 1416
    • SGi Sistemas
    • Email
Re:Botão NOVO não aparece no GRID (Consulta) quando é Mestre/Detalhes
« Responder #15 Online: Maio 03, 2016, 11:05:46 pm »
Pessoal, boa tarde.
   Para esse caso, existe um solução simples.
   Basta criar um label em que ele recebe um "iframe" com a consulta criada... e aí sim ele irá mostrar a consulta como tem que ser mostrada, com os botões.
   Saulobborges, muitas vezes utilizamos a consulta com um resumo dos dados de um formulário simples ou até mesmo um grid view.... exemplo: temos uma tela de cadastro de veiculos.. só que ela possui muitos dados... e com uma consulta simples apresentamos apenas os dados necessários, e com o botão novo chamaria o form.
   Então é isso pessoal.
At;.
Adriano
   

O Detalhe serve exatamente pra isso, na consulta é só você habilitar a opção de detalhe que apare a lupa no registro pra mostrar todos os campos da consulta, concordo que o detalhe do SC é muito estranho.
Além disso essa questão agora esta resolvida a NM resolveu liberar os botões no mestre e detalhe.

Felipe.nardi

  • Intermediário
  • ***
  • Mensagens: 119
    • Email
Re:Botão NOVO não aparece no GRID (Consulta) quando é Mestre/Detalhes
« Responder #16 Online: Março 11, 2018, 08:26:15 am »
Eu tive este problema em uma grid recentemente.
O que eu tinha feito de errado era o parâmetro na ligação que estava para não mostrar o botão novo.
Eu interpretei que este parâmetro era para não mostrar o botão novo na edição do registro e não na grid.