20% OFF para compra e renovaÇÃo »

Autor Tópico: problemas com consultas depois de atualizar pra SC5.1  (Lida 5475 vezes)

George Carvalho

  • Expert
  • *****
  • Mensagens: 1511
    • Email
Re: problemas com consultas depois de atualizar pra SC5.1
« Responder #15 Online: Agosto 12, 2010, 04:19:48 pm »
Jaqueline,

O problema é que nosso amigo esta testando com o label do campo e não com o valor.

Quanto a macro funciona, acabei de testar utilizando a Versão 5.01.0007 
« Última modificação: Agosto 12, 2010, 04:38:31 pm por George Carvalho »
George Carvalho
Porto de Galinhas/PE

danyx

  • Intermediário
  • ***
  • Mensagens: 158
    • Email
Re: problemas com consultas depois de atualizar pra SC5.1
« Responder #16 Online: Agosto 12, 2010, 04:33:54 pm »
Se 1 for 'Esperando'

if ({status} == '1')
{
sc_field_color("status","#0000FF");
}
else
{
sc_field_color("status","#008B00");
}

ou

Se 2 for 'Esperando'

if ({status} == '2')
{
sc_field_color("status","#0000FF");
}
else
{
sc_field_color("status","#008B00");
}

Vai depender do valro do 'Esperando'.
if ({status} == '1')
{
sc_field_color("status","#0000FF");
}
else
{
sc_field_color("status","#008B00");
}
Veleu George,

Tinha que passar mesmo o valor!!!

no entanto,  Quando clico em detalhes aparece esse: Parse error: syntax error, unexpected T_ELSE in C:\Program Files (x86)\NetMake\v5\wwwroot\scriptcase\app\JetClinic\grid_agendar_consulta\grid_agendar_consulta_det.class.php on line 292
« Última modificação: Agosto 12, 2010, 04:37:55 pm por danyx »

George Carvalho

  • Expert
  • *****
  • Mensagens: 1511
    • Email
Re: problemas com consultas depois de atualizar pra SC5.1
« Responder #17 Online: Agosto 12, 2010, 05:01:56 pm »
Post as linhas 291, 292 e a 293
« Última modificação: Agosto 12, 2010, 05:05:12 pm por George Carvalho »
George Carvalho
Porto de Galinhas/PE