Autor Tópico: Instalação versão 8  (Lida 75 vezes)

arrobablank

  • Novato
  • *
  • Mensagens: 16
    • Email
Instalação versão 8
« Online: Fevereiro 13, 2019, 09:43:44 pm »
Boa noite,

Estou tentando instalar a versão 8 em um servidor rodando PHP7.
No php.ini está tudo ok com o Zend e o SourceGuardian (inclusive para no test do site oficial)

"
This program makes use of the Zend Scripting Language Engine:
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with SourceGuardian v11.2, Copyright (c) 2000-2018, by SourceGuardian Ltd.
    with Zend OPcache v7.0.33-0+deb9u1, Copyright (c) 1999-2017, by Zend Technologies
"


Mas quando aponto para o diretorio de instalação, recebo mensagem: Zend Guard Run-time support missing!

Rodei o diagnosis.php e na linha Zend, fica com um X vermelho e em branco do lado:

"
Environment
   PHP: 7.0.33-0+deb9u1
   Hostname: WebAPPS
   Zend:
"


Mais abaixo o ZendId execute Permission está ok.

Enfim, parece que o scriptcase não está enxergando a instalação do Zend.

Alguma ideia? Alguém já passou por isso?

Obrigado qualquer ajuda!

Alexandre Pereira Bühler

  • Expert
  • *****
  • Mensagens: 2367
  • Focalize as oportunidades e não os obstáculos.
    • Simão & Bühler Ltda
    • Email
Re:Instalação versão 8
« Responder #1 Online: Fevereiro 14, 2019, 12:31:56 am »
Scriptcase 8 somente no php 5.4 ou 5.6 -> dica 33 ->  https://forum.scriptcase.com.br/index.php/topic,13927.msg72803.html#msg72803
Cito:

33) Qual versão do php usar?
Com Zend guard loader
scriptcase 5 -> php 5.2
scritpcase 6 -> php 5.3
scriptase <= 7.0.013 -> php 5.3
scriptcase >= 7.0.014 -> php 5.4
scriptcase 8.0.xxx -> php 5.4
scriptcase 8.1.xxx -> php 5.4 ou php 5.6
Com Source guardian
Scritpcase 9.0.xxx -> php 7.0 para IDE e php 5.6/php 7.0 para produção
Scritpcase 9.1.xxx -> php 7.0 para IDE e php 5.6/php 7.0 para produção
Scritpcase 9.2.xxx -> php 7.0 para IDE e php 5.6/php 7.0 para produção
Scritpcase 9.3.xxx -> php 7.0 para IDE e php 5.6/php 7.0 para produção
--
Alexandre Pereira Bühler
https://www.simaoebuhler.com.br
Hospedagem compartilhada. Temos servidores dedicados.
Grupo Telegram -> https://t.me/scriptcasebr
Usuário Debian, Slackware e Rwindows 10 (o videogame)

arrobablank

  • Novato
  • *
  • Mensagens: 16
    • Email
Re:Instalação versão 8
« Responder #2 Online: Fevereiro 14, 2019, 08:31:23 am »
Caramba, e eu batendo cabeça nisso o dia todo.
Muito obrigado Alexandre!

O motivo de instalar no PHP7 é que tenho uma aplicação feita no SC7 (PHP5.3), que levei pra um servidor de produção com PHP7 e só os gráficos não funcionam. Dai pensei em instalar um novo SC, aproveitando pra usar a versão 8, mas pelo visto não vai rolar....rss

Obrigado, abraço!