20% OFF para compra e renovaÇÃo »

Autor Tópico: Enviar consulta com filtro por email  (Lida 120 vezes)

aginet

  • Iniciante
  • **
  • Mensagens: 52
Enviar consulta com filtro por email
« Online: Junho 17, 2018, 01:24:54 am »
pessoal estou com um probleminha, eu tenho uma consulta e eu envio ela por email, mais quero enviar ela filtrada, então no onHeader no imoveis eu coloquei uma varial global [salvar_where] = {sc_where_current}; e coloquei como saida

no form imoveis aux eu limpei pra não aparecer os botões e nem o filtro e no sql coloqueo o [salva_where] e como saida tbem

no meu blank
eu faço uma formatação por causa dos espaços e ' e coloquei o [where] na linha q eu chamo o formulario pra enviar por email

igual esse video.
https://www.youtube.com/watch?v=VKmnwXFYbeo&t=0s

mais não esta funcionando ele esta mandando a consulta inteira e não filtra, oq pode estar errado ?

tem alguma outra forma pra eu fazer isso ?

Foto telas:

https://uploaddeimagens.com.br/imagens/35329652_1816037638488630_7931910705643520000_n-jpg

https://uploaddeimagens.com.br/imagens/35349063_1816037628488631_4287106599610220544_n-jpg

https://uploaddeimagens.com.br/imagens/35476432_1816037645155296_7254749926779781120_n-jpg

Haroldo

  • Expert
  • *****
  • Mensagens: 8607
  • Conhecimento diminui limitações.△TFA△
    • InfinitusWeb Software de Gestãol/Gestão ITIL/Consultoria Scriptcase
Re:Enviar consulta com filtro por email
« Responder #1 Online: Junho 18, 2018, 02:34:37 pm »
Eu fiz o exemplo e funcionou perfeitamente.

Você deve passar parâmetros a consulta  (Na linha de comando de execução da mesma) para ela ser filtrada, pois o comando de enviar email carrega a consulta novamente.

Não adianta vc executar a consulta filtrar e depois envia por email.

 

pessoal estou com um probleminha, eu tenho uma consulta e eu envio ela por email, mais quero enviar ela filtrada, então no onHeader no imoveis eu coloquei uma varial global [salvar_where] = {sc_where_current}; e coloquei como saida

no form imoveis aux eu limpei pra não aparecer os botões e nem o filtro e no sql coloqueo o [salva_where] e como saida tbem

no meu blank
eu faço uma formatação por causa dos espaços e ' e coloquei o [where] na linha q eu chamo o formulario pra enviar por email

igual esse video.
https://www.youtube.com/watch?v=VKmnwXFYbeo&t=0s

mais não esta funcionando ele esta mandando a consulta inteira e não filtra, oq pode estar errado ?

tem alguma outra forma pra eu fazer isso ?

Foto telas:

https://uploaddeimagens.com.br/imagens/35329652_1816037638488630_7931910705643520000_n-jpg

https://uploaddeimagens.com.br/imagens/35349063_1816037628488631_4287106599610220544_n-jpg

https://uploaddeimagens.com.br/imagens/35476432_1816037645155296_7254749926779781120_n-jpg
« Última modificação: Junho 18, 2018, 02:42:50 pm por Haroldo »