20% OFF para compra e renovaÇÃo »

Autor Tópico: Video do Youtube não aparece  (Lida 394 vezes)

adrianacombat

  • Avançado
  • ****
  • Mensagens: 369
    • Email
Video do Youtube não aparece
« Online: Maio 24, 2018, 09:15:24 pm »
Olá pessoal!

Coloquei em um cadastro um campo par inserir um vídeo pessoal. Neste campo o tipo de dados coloquei Youtube e tipo SQL lobgblog o banco é MSQL, mas insiro o link do Youtube e clico no botão para visualizá-lo e informa um erro no Id de reprodução. Fui no meu canal do Youtube, coloquei o video publico e nada de funcionar.

Vcs tem alguma idéia do que seja?

Em anexo a imagem do erro.

Aguardo retorno e obrigada
« Última modificação: Junho 15, 2018, 10:03:21 am por adrianacombat »

Ronyan Alves

  • Administrator
  • Expert
  • *****
  • Mensagens: 979
Re:Video do Youtube não aparece
« Responder #1 Online: Junho 11, 2018, 12:12:42 pm »
Altera a coluda de  lobgblog para varchar.
--

Ronyan Alves
Equipe Scriptcase

adrianacombat

  • Avançado
  • ****
  • Mensagens: 369
    • Email
Re:Video do Youtube não aparece
« Responder #2 Online: Junho 11, 2018, 07:27:43 pm »
Altera a coluda de  lobgblog para varchar.

Eu alterei e continua a mesma coisa. Mudei de video para https://www.youtube.com/watch?v=ZhCezZQqxx4 e não aparece.
Não sei oq mais fazer. Se quiser posso te enviar os arquivos pra ver, não sei oq está acontecendo mesmo.

robertobru

  • Expert
  • *****
  • Mensagens: 533
    • Email
Re:Video do Youtube não aparece
« Responder #3 Online: Junho 11, 2018, 09:19:11 pm »
Boa Noite, Adriana!

Exemplo de um link que funciona no meu sistema que disponibilizei há alguns dias em: http://jr.eco.br/videotreina/

Com o botão direito, click em - Copy embed  cod:
https://www.youtube.com/embed/iqaoVVpSWHs (link do arquivo)

Na minha tabela, link do arquivo, varchar 150.

adrianacombat

  • Avançado
  • ****
  • Mensagens: 369
    • Email
Re:Video do Youtube não aparece
« Responder #4 Online: Junho 12, 2018, 11:26:30 am »
oi Roverto.

importei tudo direitinho, mas não funciona.
coloco o link do vídeo e quando aperto a câmera não aparece o video, fica em branco apenas com o nome.
Te enviei um mensagem privada e lá aonde disponibilizou tb comentei o problema.

robertobru

  • Expert
  • *****
  • Mensagens: 533
    • Email
Re:Video do Youtube não aparece
« Responder #5 Online: Junho 12, 2018, 01:58:52 pm »
Assim tem que funcionar.
Exemplo:
No vídeo do seu canal, com o botão direito, copie o Código de Incorporação:
<iframe width="640" height="360" src="https://www.youtube.com/embed/liiAwNNWvTE" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>

Insira no link do vídeo no sistema somente o seguinte do endereço acima:
https://www.youtube.com/embed/liiAwNNWvTE

http://jr.eco.br/lc/grid_videostreinamento/ (pesquise pela palavra TESTE para verificar o vídeo que acabei de inserir)

adrianacombat

  • Avançado
  • ****
  • Mensagens: 369
    • Email
Re:Video do Youtube não aparece
« Responder #6 Online: Junho 12, 2018, 04:02:02 pm »
Roberto, vou fazer este teste q vc ta falando.
Eu ja tentei e nao foi, estou ate chateada de nao conseguir pq isso e bassico. Acredito ser um detalhe mesmo e pequeno para nao funcionar.

adrianacombat

  • Avançado
  • ****
  • Mensagens: 369
    • Email
Re:Video do Youtube não aparece
« Responder #7 Online: Junho 14, 2018, 12:15:05 am »
Rober
Roberto, vou fazer este teste q vc ta falando.
Eu ja tentei e nao foi, estou ate chateada de nao conseguir pq isso e bassico. Acredito ser um detalhe mesmo e pequeno para nao funcionar.

Funcionou Roberto!!

Copiei o código de Incorporação e deu certo, apareceu o vídeo.

Obrigada pela sua ajuda e seu código vai me ajudou bastante a entender a funcionalidade da aplicação.

Obrigada.

adrianacombat

  • Avançado
  • ****
  • Mensagens: 369
    • Email
Re:Video do Youtube não aparece (RESOLVIDO)
« Responder #8 Online: Junho 14, 2018, 10:19:38 pm »
Altera a coluda de  lobgblog para varchar.

Eu alterei e continua a mesma coisa. Mudei de video para https://www.youtube.com/watch?v=ZhCezZQqxx4 e não aparece.
Não sei oq mais fazer. Se quiser posso te enviar os arquivos pra ver, não sei oq está acontecendo mesmo.

Oi Ronyan

Na aplicação do Roberto funcionou eu inserindo o codigo de incorporação do video, mas fiz um campo video com tipo de dados Youtube e tipo SQL Varchar e não funcionou.
Ele dá o erro acima, mesmo eu colocando o link  de incorporação que o Roberto informou.
SE clico no botão Youtube aparece o erro, mesmo que o anterior.
O correto era eu clicar no botão Youtube e ele abrir e funcionar o vídeo.
Estou fazendo algo errado?
Vou colocar a imagem em outro post, pq aqui não permite

adrianacombat

  • Avançado
  • ****
  • Mensagens: 369
    • Email
Re:Video do Youtube não aparece (RESOLVIDO)
« Responder #9 Online: Junho 14, 2018, 10:20:39 pm »
Segue em anexo a imagem para conferir a configuração.

Obrigada

robertobru

  • Expert
  • *****
  • Mensagens: 533
    • Email
Re:Video do Youtube não aparece
« Responder #10 Online: Junho 15, 2018, 01:17:37 pm »
Tenta incorporar o material que disponibilizei no seu projeto.
Veja que não usei nenhum campo em referência ao youtube nas aplicações que criei.
O vídeo, propriamente dito, está dentro de um frame no controle conforme segue:

sc_lookup(rvt,"select  tid, titulo, descricao, linkarquivo from videostreinamento where tid='[sfk]'");

if(!empty({rvt[0][3]})) {
   
      {titulo}={rvt[0][1]};
   {descricao}={rvt[0][2]};
$vid={rvt[0][3]};

{video}="<iframe width='600' height='350' src='$vid' frameborder='0' allowfullscreen></iframe>";

}
   

robertobru

  • Expert
  • *****
  • Mensagens: 533
    • Email
Re:Video do Youtube não aparece
« Responder #11 Online: Junho 15, 2018, 01:21:24 pm »
Perto dos membros ferras, estou séculos atrás. Mas, fico contente em ter alcançado aqui o número de  500 participações diretas nesse fórum !

adrianacombat

  • Avançado
  • ****
  • Mensagens: 369
    • Email
Re:Video do Youtube não aparece
« Responder #12 Online: Junho 20, 2018, 04:36:50 pm »
Oi Roberto!

Eu usei sim este seu modelo, mas vou verificar com mais cuidado, pois da um erro e não aparece o vídeo.
A tabela no meu bando esta toda em uma só, vou separar esta para ver se dá certo.

Agradeço muito a sua ajuda.