30% OFF para compra e renovaÇÃo. Comprar agora

Autor Tópico: ScriptCase v9.0.035 (24/01/2018 21:12)  (Lida 413 vezes)

John L. Santos

  • Bug Tracker Team
  • Administrator
  • Expert
  • *****
  • Mensagens: 704
    • Email
ScriptCase v9.0.035 (24/01/2018 21:12)
« Online: Janeiro 25, 2018, 10:06:31 am »
Correção Específica

- Corrigido problema no retorno de uma ligação quando utilizamos a macro sc_select(where) na aplicação de origem.
- Corrigido problema ao executar a aplicação "Dashboard" no modo inicial da interface.
- Corrigido problema na visualização do lookup de exibição do campo quando condição possuía ponto.
- Corrigido problema de acentuação no label do botão da macro "sc_ajax_message", ao utilizar o charset diferente de UTF-8.


Bug

- Corrigido problema na visualização dos valores do campo "data" na interface das quebras. Será necessário limpar o cache do navegador .
- Corrigido erro de SQL especiais na consulta.
- Corrigido âncora do link do menu na documentação.
John L. Santos
NetMake - Soluções em Informática

rfriozi

  • Novato
  • *
  • Mensagens: 29
Re:ScriptCase v9.0.035 (24/01/2018 21:12)
« Responder #1 Online: Janeiro 27, 2018, 09:53:15 am »
No código abaixo:
$check_sql="SELECT * from agencias where ag_cnpj='[vagencia]'";
sc_select(dataset,$check_sql);

Quando dentro do scriptcase testando a aplicação o retorno de {dataset}->fields['ag_cnpj'] ocorre normalmente.
Quando publico a aplicação o retorno de {dataset}->fields['ag_cnpj'] é uma string ''
Estou usando a mesma base de dados em ambas aplicações.

Informo que na versão 9.0.031 isso não ocorre.

Jailton

  • Expert
  • *****
  • Mensagens: 2646
Re:ScriptCase v9.0.035 (24/01/2018 21:12)
« Responder #2 Online: Janeiro 31, 2018, 10:34:11 pm »
Amigos,

Mesmo minha conexão MySQL estando certo, tanto no Desenvolvimento quanto na Produção, na V9 nas ultimas releases,
o SC em algumas apps antigas usando sc_lookup e sc_select para carregar uma tabela, na hora de usar novamente,
este valor em soma/cálculos e para fazer insert/update em uma outra base, tem dando erro, ai dou echo na variável
de valor decimal que peguei na base usando sc_lookup / sc_select ela esta com (,) virgula no valor em vez de
estar com (.), ai estou tendo que usar a a função do php para remover antes de tentar usar estes valores:
$_Valor=str_replace(',',  '.', $_Valor);

Olhando na configuração da Conexão no Desenvolvimento e Produção esta tudo certo:


Parece que é algum Bug Interno, que esta fazendo isso, já que são aplicações antigas que nem alterei nada, e sempre
funcionaram normalmente, desde versões antigas do SC, quanto nas primeiras releases da V9.

http://www.scriptcase.com.br/forum/index.php/topic,16516.msg86821.html#msg86821
« Última modificação: Fevereiro 01, 2018, 09:10:30 am por Jailton »
O Princípio da Vibração. "Nada está parado, tudo se move, tudo vibra". Caibalion.